Resolve QuickBooks performance issues: Part 1, Overview

When working with QuickBooks over a network or with a large company file, you may experience certain types of performance issues relating to
slowness, taking a long time to open, or other similar behavior. It is important to understand the different types of performance issues that can occur:
Taking a long time to open the file.
Company file tasks slow down as the number of users signing into the file increase (multiuser environment).
Company file runs fine in the morning and slows down as the day progresses.
Performance issues for everyone in the office.
Performance issues for only one or two people in the office.
Intermittent performance issues (certain tasks are quick, while others are slow).
Similar data issues in multiple data files, indicating that the network is damaging your data files.
Be aware that every day you use QuickBooks, your data file grows larger. As your file grows, it requires more resources to operate. It is not unusual for
data files to grow too large for the installed network to support it and you will need to enhance your network.

Assure your network setup is within these recommendations:

Enhance your computers
One of the biggest improvements you will see to performance of QuickBooks is based on how much system memory (RAM) you have on the
server computer that is hosting the company file. If you have less then 4GB on your server computer, consider upgrading to a higher capacity.
See Enhance your computers to resolve performance issues for more information or contact a qualified IT professional for assistance in
upgrading your hardware.

Where your company file is stored
Where you store your company data file can have a noticeable effect on the performance of QuickBooks. Ensure that you are using a Windows

based server computer, and not a Network Attached Storage Device (NAS Drive). You can read more about the preferred company file location
by looking at Optimizing your data file location.

What kind of network do you have?
You will get the best results by having the proper network setup. The following is recommended for your network setup for peak efficiency with
QuickBooks:
A hardwired network (not wireless)
Gigabit network cards, Gigabit capable router or switch, and Cat6 networking cables. Note: 10/100 network speeds are supported, but if
you have many users, you will greatly benefit from Gigabit network speeds.
How do i know if i have a Gigabit network?
1. On your keyboard, press and hold the CTRL + SHIFT + Escape keys.
2. This will open the Task Manager.
3. Select the Networking tab.
4. Under Link Speed, see if your Local Area Connection shows 1 Gbps, you have a gigabit network. Note: If it shows 100Mbps, you do not
have a gigabit network.

How to fix it
Intuit recommends 5 solutions for resolving performance problems within QuickBooks. The first solution may solve your problem, or you may need to
try all possible solutions to resolve the issue. For best results, perform the solutions in the order shown.
Important: Some of these steps may best performed by a qualified IT professional, especially if you do not have Administrator access to your server
computer.

Be sure to update to the latest release before troubleshooting performance issues.

Solution 1: Create a backup file to reset the TLG file and resort lists
Creating a recent backup file can help improve performance in QuickBooks because it resets the *.TLG (transaction log file) used to track changes
to the company file before they are written to the database. You can read more about the transaction log file here.
1. While in the program, choose the File menu, Backup Company, and select Create Local Backup.
2. Choose Local Backup and click Options.
3. In the Tells us where to save your back up copies, choose your Desktop (or another local location).
4. Ensure that a Complete Verification is selected and click OK.
5. Choose Save it Now and click Next. In the Save Backup Copy window, choose your Desktop (or another local location) and click Save.
QuickBooks will now create a backup file to your desktop.
Resort Lists

Resort the Master Names List:
1. In the QuickBooks menu bar, choose Banking > Write Checks.
2. Click into the Pay to the order of field and press Ctrl+L.
3. Select the Include Inactive checkbox.
4. Click the Name button, and select Resort List.
5. Click OK on the message "Are you sure you want to return this list to its original order".
Resort the Item List:
1. In the QuickBooks menu bar, choose Lists > Item List.
2. Select the Include Inactive checkbox.
3. Click the Item button, and select Resort List.
4. Click OK on the message "Are you sure you want to return this list to its original order".
Resort the Chart of Accounts List:
1. In the QuickBooks menu bar, choose Lists > Item List.

2. Select the Include Inactive checkbox.
3. Click the Account button, and select Resort List.
4. Click OK on the message "Are you sure you want to return this list to its original order".

Solution 2: Test speed from UNC path and from the desktop
Open the file via the UNC path instead of the Mapped Drive:
Different kinds of network setups can have an affect on QuickBooks performance. If you typically access your company file via a mapped drive
(Q:\QB Data for example) you can try accessing the file via the UNC path (\\ServerName\QB Data).
These steps may be a bit technical, you may want to check with your IT professional if you run into any issues with getting the server computer
name or file location path.
1. Find the name of server name by opening My Computer (Windows key + E) and looking under the network location area.
2. You will see different mapped drives, such as X:\, Z:\, Y:\, etc. If you look closely, you will see the server computer name denoted by 2
backslashes (\\). This is the server computer name, make sure to write it down for the next steps. Also, you will need the shared folders
name, this is usually the name right before the server name. See example:

3. Now that you have your servers computer name and your shared folders name, put them together like this:

\\ServerName\SharedFolderName and as per the example above, the UNC path would be\\ServerName\QBData
4. Make sure to note this path down, then open QuickBooks, and choose Open or Restore a Company File.
5. Choose Open a Company File and click Next.
6. In the Open a Company box, enter in the UNC path you got from Step 3 in the file name box and pressEnter.
7. You will then see a list of your company files, choose the one you wish to open and press Open.
If the speed is faster, you will want to make sure your IT professional can set up a UNC path for future use and not use a mapped
drive to access your company files.
If the speed is the same, proceed below in troubleshooting.
Test speed locally (if on a network)

You can test QuickBooks in a multiuser environment, to determine if the network or the company file is causing the issues. If the
performances issues occur when more than 1 person signs into the company file, proceed to Solution 3. If performance issues occur with one
user logged into the company file over the network, then proceed below to copy the file local.
1. Within QuickBooks, press the F2 button on your keyboard.
2. Under File Location, make a note of where your company file is located.
3. Close QuickBooks and have all users logged into the company file log out.
4. Click the Start menu and select Computer.
5. Browse to the file path you located in step 2.
6. Once you find your company file (QBW), rightclick on it and choose Copy.
7. On your desktop, rightclick in an empty space, then select Paste.
8. Now that you have copied your file to the desktop, open QuickBooks and browse to the desktop location to open the file that you just
copied.
9. Test the performance while the file is local to see if it is faster then being on the network.
If the file is as slow as it was on the network, proceed to Solution 5 to test issues within the file itself.
If the file is faster while it is local vs being on the network, proceed below to the next solution.

Solution 3: Reduce Company File Fragments and perform Disk Defragmentation

1. While your company file is local to the desktop (from solution 1), create and restore a portable file. Note:Creating/Restoring a portable file will
help reduce file fragments in the company file, which may help improve performance.
2. After creating/restoring a portable file, perform a disk defragmentation (if your file is located on a network, go to the server computer).
Note: If the computer is using an Solid State Drive (SSD), do not perform a disk defragmentation.
a. Click the Start button and select All Programs, then select Accessories > Systems Tools > DiskDefragmenter.
b. Click the Defragment button, and follow any instructions that appear on the screen to defragment your hard drive. Note: The
defragmentation process may take some time to complete, you can start it and then proceed below to the next solution if its taking a
long time.

Solution 4: Conflicting 3rd party programs and AntiVirus software
Depending on your current setup, there may be some conflicting programs that are running along side of QuickBooks causing performance
degradation. If you use QuickBooks in a network environment, you will want to perform these steps on the server itself.
Check antivirus software

Some antivirus security programs can cause performance issues while using QuickBooks. You can try temporarily disabling it to see if
performance improves.
1. On the server computer that hosts the company file, temporarily disable the antivirus security software.
2. Open QuickBooks, and see if the performance has improved.
3. If the performance is the same, then proceed to below to check for 3rd party programs conflicting with performance.
4. If the performance is better while the antivirus program is disabled, then you will need to set exceptions to allow your security program to
bypass QuickBooks.
Important: Make sure to turn your antivirus back on after testing performance.
Check 3rd party programs

Running some 3rd party background applications can cause performance issues with QuickBooks. An easy way to diagnose if this is the cause or
not is to use Selective Startup. This will load only the basic drivers and startup items required to use your computer.

1. Press the Windows key + R on your keyboard to open the Run command.
2. type msconfig and press Enter.
3. Select Diagnostic Startup then press OK.
4. Reboot your computer and test the performance of QuickBooks.
5. If the performance is the same, then proceed to the next solution.
6. If the performance is better while in selective startup, then it is recommended you work with your IT professional to determine which
specific program is causing the performance issues.
Important: Once you have finished testing the performance in selective startup, follow these steps to get back to normal operation:
1. Press the Windows key + R on your keyboard to open the Run command.
2. type msconfig and press Enter.
3. Select Normal Startup then press OK.
4. Reboot your computer.

Solution 5: Check for issues within your company file
If you have narrowed the performance issue to the company file, as in it is slow both on and off the server computer, with the antivirus disabled,
in selective startup mode, and resetting the TLG file, you may be able to further improve performance by checking your data file for performance
enhancements.
Important: Before you begin, see if the performance is affecting multiple users or just one or two users. Also the frequency of when the
performance issues occur. Is it certain times during the day, only when doing certain types of activities in QuickBooks.
Is QuickBooks slow for all users, all of the time

If the company file is slow for everyone and all the time, you can check the data file for integrity issues. Note: If you are in a multuser
environment, it is recommended that everyone but one person log out of the company file.
1. From within your company file, select the File menu > Utilities > Verify Data.
2. Click OK to start the verify process.

3. If there are any integrity issues, QuickBooks will prompt you to run a rebuild on the data.
a. If the Verify finds errors and you run a rebuild, make sure to check your QBWin.log file for errors.
b. If the Verify completes without errors, proceed to the next step.

Is QuickBooks only slow for some users, but not others, or intermittently

Change QuickBooks Search preferences:
Go to the Performance issues in QuickBooks 2013 when the Search Index preference is enabled article.
Change other QuickBooks preferences:
You can further maximize performance by setting additional company and user specific preferences.

If QuickBooks is slow only when saving transactions (Invoices, Bills, etc):
1. Try using a new template for your transaction. Go to the Lists menu and select Templates.
2. Click the Templates button in the bottom left, and select New.
3. Choose the type of template you want to create and click OK.
4. Click the Manage Templates button in the top left.
5. Over on the right, give your new template a name and click OK.
6. Click OK again to close out of the Basic Customizing window.
7. Now use your new template on a transaction to see if the performance is improved when saving.

If after performing all these steps and you are still experiencing performance issues, Press F2 within the program and consider the following:
How large is your company file (file size)?
QuickBooks Enterprise Solutions: If your company file size is >500 MB, you cam Improve QuickBooks performance by verifying it is
using the correct amount of memory.

Do any of your lists exceed the recommended limits (list information)?
How many years worth of data do you have (versions used on this file)?

While there are no actual hard limits for the company file, performance may be impacted if you have; a large file (over 500mb for Pro/Premier and
1.5GB for Enterprise), more than 7 years worth of transactions, or are exceeding any of the list limits, you may be best suited to either condensing
your QuickBooks data or starting a new company file.
If these solutions don't resolve the issue, you can read discussions and post messages and questions relating to your issue on the Intuit QuickBooks
Community site for free. You can contact an agent for additional guidance. Fees may apply.
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Improve QuickBooks performance on your network
Many types of networks are in use today to run QuickBooks. Not all of them will run QuickBooks effectively. QuickBooks Technical Support cannot
provide support for these environments beyond basic program configuration. Even if the program is configured correctly for multiple users, Intuit
cannot guarantee performance on networks other than the recommended ones.
If you are just setting up your network, or if QuickBooks is running slowly, use this article and these resources:
Set up multiuser QuickBooks
Set up QuickBooks for multiuser access (recommended setup)
Change the setup for multiuser QuickBooks
Hosting your company data file in multiuser mode
System requirements for QuickBooks 2014 and Enterprise Solutions 14.0

Test your bandwidth speed
Prepare to test your bandwidth

1. On a file that is larger than 100 MB.
2. Using a copy of your working .qbw file so that other users can continue to work while testing is in progress.
3. Under "real operating conditions" when users are actually working in QuickBooks.
4. On all workstations that are running QuickBooks, because the bandwidth can vary with workstation.
Steps to run the test

1. Record the size, in KB, of the file you will copy .
2. Copy the file from the network location to your workstation desktop
3. Measure the time to copy, in seconds.
Calculate your bandwidth

Bandwidth = (File size x 8) / (time x 1024)
1. Bandwidth = Transfer rate in Megabits per second (Mbps).
2. File size = Size of the file in KBytes.
3. Time = Amount of time it took to copy in seconds.
4. The factor 1024 converts KBytes to MBytes.
5. The factor 8 converts MBytes to Mbits.
QuickBooks requires a bandwidth of more than 40 Mbps. If your bandwidth calculation is less than 40 Mbps, your network connection has
insufficient bandwidth to support QuickBooks. You need to identify and resolve the bottlenecks.

Additional Information.
Ways to increase your bandwidth

1. If your wireless network is providing less than 40 Mbps, hard wire some or all of the connections with CAT5 or CAT6 cables.
2. Replace hubs with switches or routers.
3. Use a 100 Mbps switch with a Gigabit port for the server.
4. Use a 1 Gbps NIC on the server.
5. Insure all your workstation NIC's are 100 Mbps or greater.
6. Adding a plugin NIC to your server and/or workstations could improve your bandwidth.
7. Multiple server NIC's can confuse QuickBooks and slow it down.
8. Limit cable length to 50  100 feet without repeaters.
9. Route cables away from electronics that generate interference.
10. Upgrade cables from CAT 5 to CAT 6. Even without Gigabit network interface cards or a Gigabit switch, CAT 6 cables can increase your
bandwidth.
11. Periodically check your network for parts that have failed: NIC's, ports and cables can fail and reduce the available bandwidth.
12. Network performance can drop off significantly in a longdistance networked environment, especially with encryption/decryption, such as a
virtual private network (VPN).

13. Intermittent errors experienced when wireless connections fail for a few seconds can disconnect your QuickBooks session. Similarly,
connection errors in longdistance networking environment (for example, a modem interruption) can cause your QuickBooks session to
disconnect.

Assure your NIC's automatically detect how fast to transmit and receive data.

1. Open your Microsoft Windows Control Panel.
2. Doubleclick System and select the Hardware tab.
3. Click Device Manager.
4. Click the + next to Network adapters to expand the list.
5. Rightclick the NIC and select Properties.
6. Click the Advanced tab.
7. Under Property, select the Link Speed & Duplex option (the option may be called something similar).
8. Click the Value dropdown arrow and select Auto (the option on you NIC could be named something else).
9. Click OK and close the window.

Gigabit Networks

1. A Gigabit network is not required to run QuickBooks, however, installing and maintaining a Gigabit network will enable QuickBooks to run
faster.
2. You will need a Gigabit Network Interface Card (NIC) in your server and in each of your workstations, a Gigabit switch and Cat 6 cables.
3. You can use a hybrid system if you have a switch with one Gigabit port for the server.

Anitvirus and Security Software

Antivirus and internet security programs are critical tools in maintaining the health and security of your computer. There is, sometimes, a cost in
performance due to the computer resources these applications use. These resources are shared by all programs, including QuickBooks. Here are few
maintenance tasks you can perform to minimize the negative effects on your computer and on QuickBooks. Note: Please be aware that Intuit does
not support firewall and anitvirus programs. Please contact your program provider for help you with installing and setting up your program.
1. Download and run the QuickBooks File Doctor to assist you in setting up your firewall.
2. Update your antivirus and Internet security software to take advantage of improved scanning engines.
3. Avoid using more than one antivirus, internet security, or firewall. Firewalls can be installed on your workstation, your server and your router.
4. Scan your hard drives frequently to protect your network from viruses and other malware.
5. As a troubleshooting tool, you may want to discontinue your antivirus software to see if your performance improves. If it does, turn on your
antivirus software and seek solutions within the antivirus settings. Do not leave your antivirus software off for any significant period of
time.

Common competing programs:

Competing programs can use RAM that QuickBooks can use to run faster. Shutting down unneeded applications and processes can enable the
operating system to allocate more resources to QuickBooks.
1. Microsoft SQL Server is not needed to run QuickBooks.
2. Microsoft Exchange Server can use large amounts of memory. Some QuickBooks users need to run the Exchange Server and QuickBooks on
separate servers.
3. Desktop search and indexing applications such as: Windows Search, Google Desktop, Copernic, Microsoft Indexing Service. You may be able to
adjust the settings within these programs to enable QuickBooks to run faster. In the extreme, you may need to disable them when working
with QuickBooks.
4. Previous versions of QuickBooks may be running data managers.
If you do not need the previous versions, uninstall them.
If you do need the previous versions, set the data manager process to start manually.

If these solutions don't resolve the issue, you can read discussions and post messages and questions relating to your issue on the Intuit QuickBooks
Community site for free. You can contact an agent for additional guidance. Fees may apply.
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Resolve QuickBooks performance issues, Part 3, Manage your computers
You can increase the performance of QuickBooks by enhancing your server and workstations.
This article is one of a set of four articles about perfomance issues in QuickBooks. If the steps in this article do not resolve your issues, tryy the steps in
the other articles:
1. Part 1: Overview.
2. Part 2: Manage your network.
3. Part 4: Manage your data file.

If these solutions don't resolve the issue, you can read discussions and post messages and questions relating to your issue on the Intuit QuickBooks
Community site for free. You can contact an agent for additional guidance. Fees may apply.

Enhance your computers
QuickBooks system requirements will support most QuickBooks users. If your network meets these specifications and you are having performance
issues, enhancing your available RAM may improve your issues. Remember your goal is not just to increase the RAM in you network, but to increase
the amount of RAM available to QuickBooks.
One rule of thumb for the amount of RAM in a server is to multiply the size of your file, in GB, by the number of your users. If your file size is 500 MB
(0.5 GB) and you have 6 users, then this rule suggests 3 GB of RAM in your server. If you have only 2 GB and you are experiencing performance
issues, consider upgrading your server to 3 GB of RAM.
Virtual Memory

1. Increase a computer's Virtual Memory (VM) to 2 GB plus 2 GB for each major application running on the computer.
2. Be sure that VM is running on an internal hard drive.
3. If your server has multiple internal drives, store the data file on one drive and the VM on another drive.
Competing Programs

A competing program is one that is running at the same time QuickBooks is running. Each competing program requires RAM and processor

capacity. You can see the competing programs by opening the Task Manager and clicking the Processes Tab.
1. Shutdown programs and processes running on a computer. This enables the operating system to assign more RAM to QuickBooks.
2. If you cannot shut down a competing program, move either QuickBooks or the competing program to another computer. A common example
is the Exchange program that runs your email system.
3. In some systems, there are too many programs running on the Domain Server for QuickBooks to run efficiently. You should consider
moving QuickBooks to another server.
RAM Enhancements

1. Add memory chips. If your server has four sockets, and 2 sockets have 1 GB DRAM chips, install two 1 GB DRAM chips in the empty sockets.
2. Upgrade the existing memory chips, e.g., replace 1 GB DRAM chips with 2 GB DRAM chips.
3. Increase workstation RAM to 2 GB. Only rarely will you need more than 2 GB of RAM.
4. Be aware of your operating system's limits on the amount of RAM it supports.
Upgrade your operating system

If upgrading RAM to 3.2 GB of RAM does not resolve your workstation’s issue, upgrade the Operating System to address more RAM. Then it can
assign more memory to QuickBooks. Upgrade your server Operating System to address more RAM, e.g., upgrade from a 32bit installation to a 64
bit installation
Upgrading Computers

If you decide to upgrade your server or a workstation, please consider the following;
1. Assure that the computer that will store the file is a true server.
2. Fill all of the RAM slots with the highest capacity chips.
3. A 64bit computer & operating system.
4. A fast clock speed of 2.2 GHz or more.
5. A fast hard drive rotational speed, e.g., 7,500 or 10,000 rpm, or a solid state drive.
6. A fast Network Interface. A 1 Gigabit per second (Gbps) card on your server can increase bandwidth.

Terminal Server

If you are running QuickBooks in a terminal server environment, you can estimate the amount of RAM on the server in two ways. The first is that
you need 0.5 GB of addressable RAM for each user. If you have five users, you need 2.5 GB of RAM. The second way is:
For 5 users, you need 23 GB addressable RAM.
For 10 users, you need 34 GB addressable RAM.
For 15 users, you need 46 GB addressable RAM.
For 20 users, you need 68 GB addressable RAM.
Note: Intuit supports Terminal Services mode only for QuickBooks Enterprise.

Where to store your data file
1. Where you store your company data file can have a noticeable effect on the performance of QuickBooks.
2. You can set up a folder in your c: root directory to store your data file and ancillary files: C:\QBData\filename.qbw.
3. Remember to move the entire data folder when you need to move the data file.
Use a networked computer

1. Store your company data file on an internal hard drive in a computer on your network.
2. Use an external hard drives or a flash drive only to back up your data file.
3. We do not recommend& using a Network Attached Storage (NAS) drive. QuickBooks for Windows is designed to store files on a computer
with a Windows Operating System, or with a Windows compatibleSAMBA share (Enterprise only).
4. QuickBooks works with a server running a RAID (Redundant Array of Inexpensive Disks). Intuit does not recommend them because
they have been linked with performance issues.
NonDedicated Server/Host

If you do not have a dedicated host or serer, use these criteria to decide on which workstation to save the file. Save your data file on the
workstation that:

1. Has the full QuickBooks program installed on it.
2. Is used by the person doing the most work in QuickBooks, to minimize data transfer over the network.
3. Has the most RAM.
4. Has the fastest clock speed.
5. Has the least nonQuickBooks activity.
Your Data Folder

When creating or moving files, QuickBooks uses these default locations:
1. Windows XP: C:\Documents and Settings\All Users\(Shared) Documents\Intuit\QuickBooks\Company Files
2. Windows 7: C:\Users\Public\Public Documents\Intuit\QuickBooks\Company Files

Optimize your network interface card (NIC) settings.

View and Edit your NIC settings

Network interface card (NIC) settings can slow the transfer rate if you have duplex mismatches. A duplex mismatch occurs when one NIC is set to
a specific link speed and duplex and is connected to a NIC set to a different value. A mismatch can reduce your bandwidth to a few Megabits per
second (Mb/s). To avoid this issue, reset all of your NIC's Link Speed and Duplex to an automatic setting.
1. Click the Microsoft Windows Start button, select Settings > Control Panel. (In some Windows versions, you do not need to
select Settings before selecting Control Panel.)
2. Doubleclick System and select the Hardware tab.
3. Click Device Manager.
4. Click the + next to Network adapters to expand the list.
5. Rightclick the NIC and select Properties.
6. Click the Advanced tab.
7. Under Property, select the Link Speed & Duplex option (the option may be called something similar).
8. Click the Value dropdown arrow and select Auto (the option on you NIC could be named something else).

9. Click OK and close the window.

KB ID# SLN54874

Resolve QuickBooks performance issues, Part 4, Manage your data file
If you are having issues with the performance of your QuickBooks installation, your company file may be the root cause. You have options you can use
to resolve such issues.
Be sure that all QuickBooks installations, including the data manager on the host /server, are running the latest release of your current QuickBooks
version. To update QuickBooks, from the menu bar, select Help and then chooseUpdate QuickBooks.
If these solutions don't resolve the issue, you can read discussions and post messages and questions relating to your issue on the Intuit QuickBooks
Community site for free. You can contact an agent for additional guidance. Fees may apply.

Your company data file size
QuickBooks' performance decreases as the size of the company file increases. There are no actual limits on the size of your company data file, but
performance may be hindered if your network is not capable of handling files that have:
More than 500 MB in Pro or Premier.
More than 1.5 GB in QuickBooks Enterprise Solutions.
More than seven years of transaction history.

Reduce the size of the company file

If you have a large file and performance is slower than what is needed, you can reduce the size of your company file. Be aware that all of these
options are complex and require a lot of time and work. You can:
Run the Condense Data Utility
Truncate your company file
This capability is not built in to QuickBooks, nor does Intuit offer truncation as a separate service. You can remove transactions up to a selected
date and then set up opening balances as of that date. You can truncate by (1) Sending your company file to a third party vendor OR (2) Obtaining
third party data transfer and opening balances applications. Truncating your file in a previous calendar year should not affect DIY with DD payroll. If
you have Assisted Payroll, consult Payroll Support before truncating your file.
Start a new company file. Starting a new company file will not affect DIY with DD payroll. If you have Assisted Payroll, consult Payroll Support
before starting a new file. If you decide to start a new company file, you have two options:

1. Use the Condense Company Data option to delete all transactions. This leaves you with a shell that has only your lists.
2. Create a new file from scratch. This sounds simple, but it is not. It is a lot of work and will take time.
a. In the old file, go to File > New Company. Follow the wizard that appears.
b. In the old file, export your lists. Open the files and clean them up by deleting inactive or no longer needed list entries.
c. Import the cleaned files into the new file.
d. Set up the opening balances. Go to www.marketplace.intuit.com to find utilities that will do this for you.

Set company and personal preferences
Company Preferences

1. Log in to your company file as the Administrator.
2. Switch to single user mode.
3. From the Edit Menu, choose Preferences.
4. Click the Company Preferences Tab.
5. In the side bar, choose Bills.
Clear the Warn about duplicate bill numbers from the same vendorcheckbox.
Click Yes in the Save Changes window.

6. In the sidebar, choose Items & Inventory.
Clear Warn about duplicate purchase order numbers.
Click Yes in the Save Changes window.

7. In the side bar, choose Sales & Customers. Clear these checkboxes:
Warn about duplicate invoice numbers .
Warn about duplicate Sales Order numbers.
Click Yes in the Save Changes window.

8. In the sidebar, choose Search.
Clear the Update automatically checkbox.
Click Yes in the Save Changes window.

9. When all of the company preferences are set, click OK.

Personal Preferences

1. From the Edit Menu, choose Preferences.
2. Click the My Preferences Tab.
3. In the sidebar, chose Desktop View.
a. Select Don't save the desktop radio button.
b. Clear the Show Home page when opening company file checkbox.
c. Clear the Show Getting Started window checkbox.
d. Click Yes in the Save Changes window.

4. In the sidebar, chose General.
Select the Keep QuickBooks running for quick startups checkbox.
Click Yes in the Save Changes window.
Note: This option is a tradeoff:
If checked, QuickBooks starts faster, but may run slower.
If unchecked, QuickBooks starts slower, but may run faster.

5. In the sidebar, chose Reminders.

Clear the Show Reminders List when opening a Company File checkbox.
Click Yes in the Save Changes window.

6. In the sidebar, chose Reports & Graphs.
a. In the Reports and Graphs section choose Don't Refresh.
Note: Reports will refresh only when you choose to do so. This preference can increase your performance if you have several reports
open while you are entering transactions.
b. Click to select the Prompt me to modify report options before opening a report checkbox.

7. When all of your personal preferences are set, click OK.

Automatic Updates

1. From the Help menu, choose Update QuickBooks.
2. Click the Options tab.
3. In the Automatic Updates section, select No.
4. Click Close.
5. Click OK.

Optimize operations
Optimize operations.

1. Reduce your DB File Fragments.
2. Resort your Master Name List (customers, vendors, employees and other names), your Chart of Accounts and and your Item List. your lists
weekly.

3. Verify your company file weekly.
4. Make a manual backup with full verification to reset the transaction log file (TLG) This backup resets your TLG to its normal size. Large TLG
files can cause performance issues. Do not delete or rename the TLG.
5. Create and restore a portable company file..
6. Do not enter zero lines on transactions. A zero line (with a zero price or quantity) adds another target to your data file and increases the size
of your data file. Zero lines slow QuickBooks' performance and, if you run cash basis reports with inventory, your COGS could be incorrect.
7. Run accrual reports instead of cash reports: Many transactions, e.g., more than 50,000, tend to degrade the Sybase Sequel server. Cash basis
reports take longer to run because QuickBooks must check a transaction's links to determine what is paid and unpaid.
8. If QuickBooks runs slowly when doing payroll, have other users log off and do payroll in single user mode.
9. Close QuickBooks windows that you are not currently using.
10. Clear the queues of forms to be printed or emailed.
11. If you are the only user in the data file, switch to single user mode.
12. Reboot your workstations daily.
13. Log out of the data file if you are not actively using it and do not stay logged in to the company file overnight
14. Perform long tasks in offpeak hours (email or print batches of invoices or statements) in the offhours (before normal hours, lunch time
or overnight)so they do not take resources from other users.
15. Optimize reports. Running reports is an intensive operation within QuickBooks because the can draw on a lot of data. Optimizing reporting and
printing reports can save considerable time and resources. The Sales Tax Liability Report and the General Ledger report tend to be long
reports. Here are some hints:
a. Run long reports in the offhours, during lunch, overnight, over the weekend.

b. Customize and memorize long reports.
c. Copy your company file to an unused workstation, set the driver to print directly to the printer and print your report.

Maintain lists
List characteristics that can hinder performance.

1. Your lists are approaching the list limits.
2. Your lists have a large number of inactive entries that you no longer use.
3. Your customer list has many jobs underneath customers.
4. Your account list has many subaccounts.
5. Your item list has many subitems.
6. The Customer, Vendor, and Employee centers have customsorted name lists.
WARNINGS Before doing any of the steps below
1. Create a backup of your data file.
2. Be aware that once two entries are merged together, the merge can not be undone.
3. Create an archive copy of your file. If you merge any list entries , open the archive copy to view the history of the merged entries .
Custom Sorted Lists.
1. Open the center that has performance issues.
2. To the left of the Name column, ensure there is no diamond column.
3. If there is a diamond column, click the diamond to remove it. You do not need to be in singleuser mode to remove the diamond.
4. Close the center and reopen it.

Modify Lists

Chart of Accounts: If you are using subaccounts to track source of income or use of expenses, merge subaccounts together or into the parent
accounts and set up Classes to do the tracking.
Item List: Merge together old and/or inactive items that are no longer sold. Merged items lose their identity; be sure you have an archive copy
with the history of each item.
Customer LIst: If your Customer:Job list has several, old jobs underneath Customers, merge them together. If you have old, inactive Customers
to whom you no longer sell, merge them together. The merged customers and jobs lose their identity; be sure you have an archive copy with their
individual history.
Vendor List: If you have old, inactive Vendors from whom you no longer purchase goods, merge them together. The merged vendors lose their
identity; be sure you have an archive copy with their individual history.
Employee LIst: If you have old, inactive Employees whom you no longer employ, merge them together. The merged employees lose their
identity; be sure you have an archive copy with their individual history and be sure that you have all of their tax forms up to date, printed and
submitted to the appropriate tax agencies.
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